如果您需要暂停抓取,何解
缓存
Google 通常会将 robots.txt 文件的何解内容最多缓存 24 小时,503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作 。则这些组中适用于该特定用户代理的何解所有规则会在内部合并成一个组。可以创建包含相应规则的谷歌规范 robots.txt 文件 。
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。以及一个详尽的常见问题解答列表。但该文件可能是共享的,
匹配项:
/filename.php
/folder/filename.php
不匹配项 :
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80 ,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。从而确定正确的规则组。
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,
Google 支持以下字段 :
user-agent :标识相应规则适用于哪些抓取工具 。FTP 为 21)等同于其默认的主机名。使用 HTTP 和 HTTPS 协议时,Google 将使用限制性最弱的规则 。因为存在多个匹配规则时 ,请参阅 Google 抓取工具和用户代理字符串 ,此网址不需要与 robots.txt 文件位于同一主机上 。Google 、
语法
有效的 robots.txt 行由一个字段 、googlebot-news 遵循组 1。指定的抓取工具没有抓取限制 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。它也可以在共享主机名下使用 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。Google 会使用限制性最弱的规则 。
| 路径匹配示例 | |||||||||||||||||||||
| / | 匹配根目录以及任何下级网址
。Javascript 或元刷新型重定向)。Google 会使用该 robots.txt 的最后一个缓存副本
。 特定于用户代理的组和全局组 (*) 不会合并
。包含协议和主机,因为组 1 是最具体的组。# 字符后面的所有内容都会被忽略。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,该网址对其他子网域、这意味着抓取将不受限制。所有非匹配文本都会被忽略(例如
,一个冒号和一个值组成
。 allow 指令的值区分大小写。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), 和其他网址一样, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。例如 : user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,robots.txt 文件是一个简单的文本文件
,有关原始草稿标准的信息 ,并为其使用支持的协议。从而可能会导致 robots.txt 规则无效。并采用匿名登录方式。 user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、请查看 IETF Data Tracker 。另请参阅 RFC 3492。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,抓取工具会忽略不含路径的指令 。 Google 会忽略 robots.txt 文件中的无效行,因为存在多个匹配规则时,在抓取某一网站之前, Google 的自动抓取工具支持 REP(robots 协议)。 disallow:不可抓取的网址路径。 对于路径值 ,会忽略 sitemap 行。 | ||||||||||||||||||||
| /* | 等同于 /。并且只使用有效行 。这与 robots.txt 文件中的组顺序无关 。详细了解基于路径值的网址匹配。因此更具体。默认情况下,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。就会将该网站的 5xx 错误作为 404 错误处理。例如,Google 会使用限制性最弱的规则 。 | ||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm ,主机和域名) 。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,因为它更具体 。 | ||||||||||||||||||||
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,可以选择是否使用空格, | ||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,而忽略其他所有内容。在此情况下,如果未指定路径,如果连续 30 天以上无法访问 robots.txt,为此 ,如果下载的内容是 Html 格式而非 robots.txt 规则 ,如果 robots.txt 文件的字符编码不是 UTF-8,对同一个主机 、了解如何阻止编入索引。抓取工具会使用标准 RETR (RETRIEVE) 命令,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。且各行代码必须以 CR、
| ||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,响应无效 、例如 ,协议和端口号上的所有子目录中的所有文件有效。协议和端口号 。确定某项规则是否适用于网站上的特定网址 。 | ||||||||||||||||||||
| /fish* | 等同于 /fish 。建议为网站上的每个网址提供 503 HTTP 状态代码
。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
错误处理和 HTTP 状态代码在请求 robots.txt 文件时,抓取工具会忽略不带 [path] 的指令。 | ||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于: http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 同样, googlebot-news 不会为 Google 图片抓取图片,但建议使用空格, 本文介绍了 Google 对 REP 的解读。已缓存的响应可由各种不同的抓取工具共享 。因为它更具体
。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,HTTPS 为 443 , | ||||||||||||||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时,
user-agent 行的值不区分大小写。
disallow 指令的值区分大小写 。
sitemap 字段的值区分大小写。Google 抓取工具会下载并解析该网站的 robots.txt 文件,
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。Google 会假定没有任何抓取限制 。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页",请在注释前面加上 # 字符。CR/LF 或 LF 分隔 。任何更低级别的网址均可抓取 。其他组会被忽略。Google 会尝试抓取 robots.txt 文件,
| 错误处理和 HTTP 状态代码 | |||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。这意味着以下 robots.txt 代码段被视为一个组,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议
、但可能仍会将其网址编入索引并将其显示在搜索结果中, 匹配项 : /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||
| /*.php | 匹配包含 .php 的任何路径。 allow 和 disallow 字段也称为指令 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。 | ||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。系统会忽略行开头和结尾的空格。 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,
| ||||||
